Bot - Outage
Incident Report for Ticket Tool
Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 16:13 CST
Identified
Ticket Tool White/Free is starting back up once again..
Posted Feb 27, 2023 - 15:40 CST
Investigating
Discord has forced me to re-shard the free bot to a new shard count, This will extend the outage.
Posted Feb 27, 2023 - 14:21 CST
Update
Starting Ticket Tool back up, eta for full recovery 30 minutes.
Premium Bot is online.

This issue isn't fixed, I've just applied an update to stop the crash, Some parts of the bot might not function.
Posted Feb 27, 2023 - 14:10 CST
Identified
We've been in contact with the Discord team and they're working to reverting the breaking api changes.
Posted Feb 27, 2023 - 13:48 CST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2023 - 13:32 CST
Update
we can confirm multiple other bots are also having this issue, looks like Discord pushed a breaking api change.
Posted Feb 27, 2023 - 13:28 CST
Investigating
At this time Ticket Tool's experiencing outages, we're looking into the issue.

Discord.js Error: channel.isTextBased is not a function
Posted Feb 27, 2023 - 13:04 CST
This incident affected: Primary Bot and Premium Bot.